Saturday, November 27, 2010

Iomega ScreenPlay Director HD review/hacks

I bought the iomega ScreenPlay Director HD a few weeks back. Hardware wise the product is perfect. The only place where it really lets you down is the software. Calling the UI on this system ugly would be an understatement of the century. To top it all none of the advertised features like Youtube and Shoutcast work. If you want to copy a file over the network get ready to sleep. The speed is no more than 10MBps and again that is on the higher side, it more like 4-5 MBps. If you want to copy all your stuff you will have to copy it using USB. The Ethernet cable will not really help you. I had initially thought that I would use it like a NAS but that seems almost impossible with such a slow speed.

I figured since this system runs of Linux I would be able to somehow telnet into the system. This system is completely locked down. I've been searching quite a bit to figure out ways to atleast telnet but so far all the efforts have not yielded any results. I still don't get it, if iomega cannot provide good quailty software why don't they atleast let others who know how to develop software tinker with the device.

If you are looking for places to find information about how to get started with hacking the device here are a few links which can get you started. If you somehow figure out a way to telnet please do let me know.

http://foro.wydev.es/ - Forum is in Spanish but some good information. You can use Chrome with its auto translate mode incase you don't know Spanish.

http://www.iomegasupportforums.com/ - This is the official forum and surprisingly its not indexed by Google so will very rarely see the links using Google.

There is one very interesting piece of information in the forums if you try http://screenplay-550c:49152/, here screenplay-550c is name or ip of the device. It returns a 500 Internal Server Error. So there is a webserver running on the device. I think its got to do something with UPnP A/V & DLNA Media Server.

UPDATE (March 12th, 2011): I read in the forum that you can mount the hidden partitions using JFSutils.

5 comments:

Naughty said...

http://download.iomega.com/resources/whitepapers/ix-forward.pdf
..
should answer 49152 port question.
i'm looking some help with this box too..
i've been using this box for more than a year now, & has started to throw a username/password dialog box when i try to copy from network.
cheers
naughtyballs at gmail

Anonymous said...

Yeah this is one of the worst gadgets i did ever get. I assumed that it would be an upgrade of screenplay pro with mkv support and purchased it.

No firmware update , not proper support and when spoke to iomeaga support personnal , they mentioned to buy a newer version which has all the issue solved !

Anonymous said...

Did you figure out how to mount the hidden JFS patition? Is so, how did you do it?

Vivek Jishtu said...

I personally did not try and mount it again but I read in the forum that someone out there was able to mount it using JFSutils. This person was using Ubuntu. Unfortunately the forum seems to be down for the last few weeks now.

Anonymous said...

This is the worst gadget of the century.I got this box thinking that i would be an advance box than the screenplay pro which had a lot of functions . I contacted iomega 3 times and did meet some of the officials at expo and did vent out my feelings. But no use.